Nuevo número : Todo Linux 80

Todo Linux 80Contenidos:

AMP (Apache+MySQL+PHP) paso a paso

Reportajes Búsquedas P2P con YaCy

Zona Iniciación/Debian:
Estudiando el arranque del pc con Linux
Portátiles con Debian

Talleres Prácticos
Curso de Gimp: Primera práctica
Instalando el entorno del Arduino
Máquinas virtuales: VMware Server y Player

Análisis de software
Pandora: el sistema de monitorización libre
K3b 1.0, CDs y DVDs desde Linux

Hardware
Desktop: Impresora HP Laserjet 2820 en red
Servidor: Almacenamiento IP

En el DVD: Fedora 7

Nuevo número revista Linux+/Julio

Linux+ DVD 07El tema de este número de Linux+ es Multimedia. En los DVD’s adjuntos encontraréis:

# Ubuntu 7.04
# Mandriva 2007 Spring
# Programas comerciales:
AVChat – Audio y video chat software basado en Flash Communication Server,
versión hasta 10 usuaruis simultáneos, valor 75 euro
SmartSVN – un cliente gráfico para Subversion, valor 57,50 euro

También podréis leer los siguientes artículos:

# Video en Linux
Creación y edición de películas
# QDVD-Author
Un proyecto básico de DVD
# El cine en PSP
Pasa películas a tu Playstation desde Linux
# Software Libre en la PYME
Conocer Squid 2.6
# Django
Desarrollo Web con Python II
# C# con Mono en GNU/Linux
Desarrollo de software con el proyecto Mono
# Gráficos en PHP
# Cake PHP
El paradigma Modelo-Vista-Controlador
# Reproductores Multimedia

Actualización crítica del plugin de Flash para Linux

Recientemente se ha hecho público un boletín de seguridad en el que se informa de  una vulnerabilidad en el plugin de Flash para Linux, Windows, Mac y Solaris que podría permitir la ejecución remota de código arbitrario, lo cual clasifica esta vulnerabilidad y el parche consiguiente en el apartado de crítico (traducido: actualizar el plugin de Flash a toda leche si no queréis que vuestra máquina Linux se convierta en un zoombie controlado a distancia)

Instalar una webcam Logitech QuickCam Notebook Deluxe

Camorama webcam : JuananUna nueva compra de un nuevo gadget: una webcam Logitech QuickCam for Notebooks Deluxe (firma lsusb: 046d:08d8 ) . Antes de comprarla, miré la lista de compatibilidad http://mxhaard.free.fr/spca5xx.html . Este señor ha desarrollado un driver genérico para soporte de más de 200 webcams distintas (compartiendo chipsets parecidos). Lo primero: la webcam no logré hacerla funcionar ni en Ubuntu Dapper ni en Edgy, razón (una más) por la que decidí actualizar a Feisty. Ahí sí, siguiendo estos pasos (usando GCC 4.0 en lugar de GCC 4.1, ver post anterior)


# apt-get install module-assistant
# apt-get install gspca-source
# m-a prepare (sí, es un comando raro, la abreviatura de module-assistant)
# m-a a-i gspca
# modprobe gspca
# apt-get install camorama
# camorama

Para que cualquier usuario pueda usar la webcam, hay que dar permisos al dispositivo /dev/video0:

# chmod 0666 /dev/video0

Si tienes problemas en la instalación o prefieres hacerlo todo a mano (así podrás descargar y compilar la última versión del driver genérico gspca) puedes seguir las siguientes intrucciones (están en francés, pero se entienden perfectamente)

¿Problemas instalando ndiswrapper?

Durante estos días he estado convirtiendo mi antigua EHUX 2 (basada en Dapper) a Ubuntu Feisty Fawn. El proceso es largo y lo explicaré otro día, pero por resumir, consiste en actualizar dapper a la última versión de todas las aplicaciones instaladas, hacer un upgrade a Edgy y de ahí un upgrade a Feisty. Este último paso lo he tenido que hacer de forma manual en dos portátiles (no funcionaba el do-release-upgrade de update-manager) En fin, el caso es que una vez terminado el proceso la tarjeta wireless ha dejado de funcionar. Y como la uso a diario, no he podido irme a dormir sin arreglar el entuerto… El problema aparecía en el arranque. Se veían líneas indicando que Feisty no ha podido cargar ndiswrapper (es la aplicación que uso para poder usar mi tarjeta wireless). Solución: descargar el código fuente de ndiswrapper, compilar e instalar. Pero no podía ser tan facil 😉

En la compilación ya avisaba con un WARNING: ndiswrapper: Unknown symbol __stack_chk_fail

Y al intentar cargar el módulo  he podido corroborar que algo no le gustaba al kernel:

# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper
(/lib/modules/2.6.15-26-386/misc/ndiswrapper.ko): Invalid module format

Veamos si podemos sacar más info :

# dmesg
ndiswrapper: version magic ‘2.6.15-26-386 preempt 486 gcc-4.1’ should be ‘2.6.15-26-386 preempt 486 gcc-4.0’

¡Vaya! tras mucho googlear, al parecer ndiswrapper no se puede compilar con gcc-4.1 (no se puede, punto) y hay que compilarlo con gcc-4.0  ¿Cuál he usado yo?

# gcc -v

[…]  gcc-4.1

Pero si hago apt-get install gcc-4.0, Ubuntu me dice que ya estoy en la versión más nueva de GCC y que además, ya tengo el GCC-40 instalado. Vale, ¿me voy a dormir? No! Tras seguir estas magníficas instrucciones

(---FORCING USE OF GCC-4.0---)
cd /usr/bin
sudo rm gcc gccbug
sudo ln -s gcc-4.0 gcc
sudo ln -s gccbug-4.0 gccbug

(---COMPILE NDISWRAPPER AT STEP 2---)

(---UNDOING ABOVE CHANGES TO REVERT BACK TO GCC-4.1---)
cd /usr/bin
sudo rm gcc gccbug
sudo ln -s gcc-4.1 gcc
sudo ln -s gccbug-4.1 gccbug

Se arregla el problema 🙂  Ahora sí…. a dormir…